Close

Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,388

    Default Re: midi in not working in SS 5.7

    Cary,

    I would assume that you are using an external MIDI controller with the SFZ plugin using the MOTU as the MID interface...correct?

  2. #12

    Default Re: midi in not working in SS 5.7

    Quote Originally Posted by mr_es335 View Post
    Cary,

    I would assume that you are using an external MIDI controller with the SFZ plugin using the MOTU as the MID interface...correct?
    Yes, that is what I did/do.
    Cary B. Cornett
    aka "Puzzler"
    www.chinesepuzzlerecording.com

  3. #13

    Default Re: midi in not working in SS 5.7

    Looks like I need to start over with this troubleshooting process.

    I have a test session set up in SawStudio. There is a VSTi loaded on audio track 1. It is RGC Audio's SFZ. I have used this successfully in more than one project. This particular session file worked when I originally set it up months ago. I have Midi Workshop installed, and have used it successfully in the past. I do not have any active tracks set up in MWS in this EDL file, not even a midi port selection for any track on MWS.

    First I fire up SawStudio, and I check to see that audio and midi devices show up as available in the audio setup and midi setup dialogs. Audio devices are fine. When I do the drop-down lists for available midi ports for midi control device setup, all five ports each way on my MOTU Micro Lite interface are listed as possible selections. I have no other MIDI interface attached to the computer. I have tested the Micro Lite using Midi-Ox and verified that it works. Midi-Ox is CLOSED, not running when I run SawStudio. Task Manager lists no other applications.

    When I open my VSTi test EDL, it loads and an error message pops up
    "Midi device in driver is currently not available".
    I click OK. Then I click the blue triangle in the window for the SFZ VSTi, click to select a midi in port, and a list pops up showing the 5 ports on the Micro Lite plus the virtual ports for MWS. I select a port and the error message pops up
    "Midi device in driver is currently not available".

    I have tried disconnecting and reconnecting the Micro Lite and I re-ran all tests, with no change in any result. Testing with Midi-Ox shows that the port works. I tried going back to version 5.6 of SS. No change in results. The interface is on, it is working, SawStudio can see that it exists, but for some reason cannot access it, even though there are NO other programs running. This same interface worked fine with SawStudio on the same computer a few months ago.

    I'm not sure where to go from here.
    Cary B. Cornett
    aka "Puzzler"
    www.chinesepuzzlerecording.com

  4. #14
    Join Date
    Mar 2015
    Location
    Alberta Canada
    Posts
    61

    Default Re: midi in not working in SS 5.7

    Cary...I'm a bit of a midi idiot...but here is my 'shot in the dark'....check you midi controller(keyboard?) make sure its working(off/on switch?) Forget about your EDL or Midi Workshop. First turn your controller ON...THEN launch SAW, load your VSTi...then under Options/Midi device setup, select under Midi-Control Device In...your controller NAME, should show up here. My 2 octave midi controller keyboard, plugs in to a USB port and shows up under 'Midi-Control Device In' as "masterkeys 25"...then configure your VSTi, under Set SoftSynth Midi-In Port, click on '01 THE NAME OF YOUR CONTROLLER'...then press play or right click the play button for live mode...and then play away. I've tested this all out with a VSTi and it works....again check your midi controller....
    Laughing Crow Studios
    Alberta Canada

  5. #15
    Join Date
    Mar 2015
    Location
    Alberta Canada
    Posts
    61

    Default Re: midi in not working in SS 5.7

    ....is your controller plugged in to a midi in or a midi out port...
    Laughing Crow Studios
    Alberta Canada

  6. #16

    Default Re: midi in not working in SS 5.7

    Cary... look at the midi device setup in the Midi Workshop... make sure your MOTU device is NOT selected there as one of the midi devices... if so... that device is taken and cannot be assigned anywhere else... hence the warning message.

    Bob L

  7. #17
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,388

    Default Re: midi in not working in SS 5.7

    Carey,

    Have a peep: Using an External Keyboard with SAW/MWS

    Note: Others may benefit from this tutorial as well.

  8. #18

    Default Re: midi in not working in SS 5.7

    Quote Originally Posted by Bob L View Post
    Cary... look at the midi device setup in the Midi Workshop... make sure your MOTU device is NOT selected there as one of the midi devices... if so... that device is taken and cannot be assigned anywhere else... hence the warning message.

    Bob L
    That was the correct answer! I had forgotten that I usually work by putting an MWS track in record ready with midi thru, then selecting a virtual port to feed the VSTi.

    Suggestion:
    If a midi port is assigned to MWS, it should not show up in the selection list from the blue triangle in the VSTi window. This could save some confusion.

    Thanks!
    Cary B. Cornett
    aka "Puzzler"
    www.chinesepuzzlerecording.com

  9. #19

    Default Re: midi in not working in SS 5.7

    I believe the list boxes should show all devices connected to the system... in some cases the same device can be used by multiple programs at the same time.

    By the way... there is no need to place a track in rec rdy mode to hear the signal thru... simply use Live mode to activate all vsti synths for testing.

    Bob L

  10. #20
    Join Date
    Nov 2007
    Location
    Clermont-Ferrand / France
    Posts
    261

    Default Re: midi in not working in SS 5.7

    Quote Originally Posted by mr_es335 View Post
    Carey,

    Have a peep: Using an External Keyboard with SAW/MWS

    Note: Others may benefit from this tutorial as well.
    You can also enable/disable Live mode by right cliking the blue triangle of your VSTi windows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •