Close

Results 1 to 8 of 8
  1. Default Problem with midi template

    Hi

    I have recently started using the "Mackie MCUPro 24ch" miditemplate with Icon Platform X controllers. The template works fine unless I try to control Out01. If I move the fader on the controller it moves the Out01 fader in SAC but as soon as I lift my finger from the controller the fader jumps back to it's starting position. If I use a mouse and move the Out01 fader in SAC the fader on the controller doesn't move. It would seem that SAC is not "looping back" the Out01 faders position/value to the controller.
    Apparently it's only Out01 that has a problem. Both the 24ch templates with and without meters give me the same behaviour. Out01 works fine with the 8ch and the 16ch templates.

    I was hoping someone here could test the behaviour of the Mackie MCUPro 24ch template on their system, and let me know if they can get Out01 working?

    I'm on SAC 4.6a
    Peter Olsen

    Hardware: Asus TUF Z270 mark 2, Intel Core i3-7350K, 8 GB ram, 250GB NVMe SSD, 2 RayDAT, 2 DSB2408 preamp/converters.
    OS: Windows 10. Buffer: 1X32.

  2. #2

    Default Re: Problem with midi template

    Try using the Icon Templates and see what happens.

    Bob L

  3. Default Re: Problem with midi template

    The Icon template works. I guess I'll use that one then!
    Peter Olsen

    Hardware: Asus TUF Z270 mark 2, Intel Core i3-7350K, 8 GB ram, 250GB NVMe SSD, 2 RayDAT, 2 DSB2408 preamp/converters.
    OS: Windows 10. Buffer: 1X32.

  4. #4

    Default Re: Problem with midi template

    Yup... The Icons are not 100% Mackie compatible... almost... but there are small differences.

    Bob L

  5. Default Re: Problem with midi template

    I still find it odd that the 8ch and the 16ch versions work with Icon controller but the 24ch doesn't?! But my problem is solved, so I'm happy :-)
    Peter Olsen

    Hardware: Asus TUF Z270 mark 2, Intel Core i3-7350K, 8 GB ram, 250GB NVMe SSD, 2 RayDAT, 2 DSB2408 preamp/converters.
    OS: Windows 10. Buffer: 1X32.

  6. Default Re: Problem with midi template

    I have discovered a problem with the ICON midi template: When I load a session with about 20 inputs 4 monitor sends and a good handful of plugins (approx. 30% cpu usage), engage the SAC engine and try to rename a channel, the OK button doesn't show on the editbox and SAC freezes! As long as the engine is not engaged there is no problems with renaming.

    With a "lighter" session it just takes a little while for the OK button to appear on the editbox, so SAC does not remain frozen for more than a couple of seconds. The problem seems to be worst when I try to edit the name of a channel that is not currently the selected channel (by pressing CTLR + left clicking on a different channel).

    Luckily this bug bit me pre show, but it could have gone very bad :-(
    Peter Olsen

    Hardware: Asus TUF Z270 mark 2, Intel Core i3-7350K, 8 GB ram, 250GB NVMe SSD, 2 RayDAT, 2 DSB2408 preamp/converters.
    OS: Windows 10. Buffer: 1X32.

  7. #7

    Default Re: Problem with midi template

    Check for sure if this has anything to do with the Midi Template... test it without the Icon Template active... my guess is that something else is going on with your setup and possible dialog hooks from some utility program... the OK button should have nothing to do with Midi Control.

    Bob L

  8. Default Re: Problem with midi template

    I think it's related to the Icon template in some way. I can not replicate the problem with any other template including the Mackie MCU ones.
    My guess is that the problem has to do with the constant stream of midi events that the Icon template generate. All the events somehow "overflow" the system.

    It would be nice if someone on this forum would load up a session on their pc, load the "MidiCtrl_Mackie_MCUPro_No_Meters_24Ch_Ex_Ex_Pro.m ct" midi template, assign some midi ports to the 3 Midi-Ctrl-Devices in the "Midi Device Setup", activate "Midi-Control In" and "Midi-Control Out", activate the SAC engine, and finally try naming/renaming channels and report back here if SAC freezes or not?
    Peter Olsen

    Hardware: Asus TUF Z270 mark 2, Intel Core i3-7350K, 8 GB ram, 250GB NVMe SSD, 2 RayDAT, 2 DSB2408 preamp/converters.
    OS: Windows 10. Buffer: 1X32.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •