Close

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
  1. Default Re: Dropped buffers again

    Quote Originally Posted by cgrafx View Post
    The Idle screen is the screen saver and even the if its set to just blank the screen it causes dropped buffers on my test system.

    I would not recommend letting process lasso do anything other than set CPU affinity and priority. Do not let it optimize your system tasks or it will be making arbitrary decisions about what to run and when.

    Its an expensive utility to set affinity and priority, but I couldn't find any other utilities that would do that reliably without causing other problems.
    Thanks. I like Process Lasso. It is worth it to me. So are you saying I can turn off "Enable Pro Balance"? Should I exclude system tasks? I am certainly getting closer to "no dropped buffers". The system will run for hours with no dropped buffers, but if I let it run over night, I still get a few.

  2. #12
    Join Date
    Jul 2006
    Location
    SF Bay Area
    Posts
    1,174

    Default Re: Dropped buffers again

    Quote Originally Posted by dbarrow View Post
    Thanks. I like Process Lasso. It is worth it to me. So are you saying I can turn off "Enable Pro Balance"? Should I exclude system tasks? I am certainly getting closer to "no dropped buffers". The system will run for hours with no dropped buffers, but if I let it run over night, I still get a few.
    Yes, my recommendation would be to turn off "pro balance".

    It may not have any affect on your dropped buffers, but its also a running process that really doesn't need to be there.

    Also note if you haven't made the change yet. Running at 4x64 will have higher latency then running at 1x128. 1x128 will reduce your system load and relax buffer timing. So if your only dropping a few buffers at 4x64, you will like drop 0 at 1x128. You really don't need the extra pre-buffers.
    Last edited by cgrafx; 09-17-2019 at 10:03 AM.
    ---------------------------------------
    Philip G.

  3. Default Re: Dropped buffers again

    O.k. I got it all working at 1-128. It ran overnight with one dropped buffer. I think that was from starting Foobar, which I have playing music through the S-PDIF loopback of the RME RayDAT card and back into a SAC channel. I restarted SAC this morning and it ran all day with no dropped buffers. I'm not sure what the "cure" was, but the last thing I did was to stop TimeBrokerSvc (Runtime Broker), which kept popping up in Process Lasso. When I got home around 6pm CST I stopped SAC and reset the buffers to 1-64. That has now been running for two hours with no dropped buffers.

    On a side note, as I said, SAC has been running on my powerful notebook computer (i7, 8 cores) with no dropped buffers for the last several months, so I set up my smaller Dell XPS-13 notebook to run SAC, connected to my RME BabyFace as a test. It had no dropped buffers from the get go at 1-64 buffers. The rack system with the Gigabyte motherboard was somehow configured by Windows 10 to have all these goofy background services running. I have my fingers crossed, but it looks like I got all the culprit services shut down, so they won't stomp on SAC anymore. Thanks for all your help. Process Lasso was invaluable in identifying all these different services that were popping up, causing dropped buffers and then shutting down. Without being able to see the processes that had run and then shut down, I don't think I would have arrived at a solution.
    Last edited by dbarrow; 09-18-2019 at 06:19 PM.

  4. Default Re: Dropped buffers again

    So awesome! I got this rig to run at 1-64 buffers overnight with no dropped buffers. I think the main culprit was RuntimeBroker, or "Time Broker" in the services menu. Apparently, it runs the "tiles" feature of Windows 10 and maybe some other features I don't use. I just stopped it in Services.msc, but here are a couple of posts on how to keep it from loading via the registry:

    https://www.tenforums.com/performance-maintenance/12707-stop-runtime-broker-running-constantly-background.html

    https://www.tenforums.com/network-sh...r-process.html





    Last edited by dbarrow; 09-19-2019 at 09:16 AM.

  5. #15
    Join Date
    Jul 2006
    Location
    SF Bay Area
    Posts
    1,174

    Default Re: Dropped buffers again

    Quote Originally Posted by dbarrow View Post
    So awesome! I got this rig to run at 1-64 buffers overnight with no dropped buffers. I think the main culprit was RuntimeBroker, or "Time Broker" in the services menu. Apparently, it runs the "tiles" feature of Windows 10 and maybe some other features I don't use. I just stopped it in Services.msc, but here are a couple of posts on how to keep it from loading via the registry:

    https://www.tenforums.com/performance-maintenance/12707-stop-runtime-broker-running-constantly-background.html

    https://www.tenforums.com/network-sh...r-process.html

    Glad to hear and thanks for following up with details.
    ---------------------------------------
    Philip G.

  6. Default Re: Dropped buffers again

    Quote Originally Posted by cgrafx View Post
    Glad to hear and thanks for following up with details.
    I went through a similar week of sorting out crap like this years ago, but that was an entirely different set of Windows issues from an earlier version. It is all still documented on the forum somewhere. I used some of that as a starting point this time. that may have even been the same rackmount computer. I have mostly been using my notebook computer with SAC64 connected to an RME Fireface UFX for 28 inputs. That all has worked flawlessly and it doesn't take up much space. I also have the SAC rack I built for a band I used to work with, that couldn't figure out SAC after I left, so they moved to X32. I traded them my X32 for the SAC rack. I would rather have it. It still uses XP, but I may rebuild the guts of that computer with modern fare and get SAC64 up and going on that. I suspect it will all just work, without all this extra tweaking. Ifnot, I know right where to go and what to do.
    Last edited by dbarrow; 09-19-2019 at 12:18 PM.

  7. Default Re: Dropped buffers again

    Crap! I set the buffers to1-32 and got some dropped buffers, Now,after I set it backto 1-64, I keep getting buffer drops again. I didn't change anything else. I guess I rebuild another computer with more modern parts.

  8. Default Re: Dropped buffers again

    Quote Originally Posted by dbarrow View Post
    Crap! I set the buffers to1-32 and got some dropped buffers, Now,after I set it back to 1-64, I keep getting buffer drops again. I didn't change anything else. I guess I rebuild another computer with more modern parts.
    I just updated to Windows10 1903, updated SpyBot Anti-Beacon, which turns off some telemetry services, nulls out telemetry IP addresses and such, and now I have had SAC running at 1-64 for several days with no dropped buffers. I was reluctant to update to 1903, because one of my other studio computers also has Pro Tools, which hasn't been certified for anything past 1803. I took a chance, updated that one to 1903 and Pro Tools does run with Windows 10 1903. I think Microsoft must have added some improvements that are more friendly to audio and video related programs.

  9. Default Re: Dropped buffers again

    I also updated my notebook computer to Windows 10 1903 from 1803. It has been running SAC all day, with music playing via foobar2000 through the wdm2 vst plugin on a stereo SAC channel, 24 other active tracks. I also have Firefox and Chrome open, ran another Audio/Video program, Transcibe!, all at the same time. SAC is set to 1-64 on this computer. NO DROPPED BUFFERS! I think they must have improved some performance aspects of Windows 10 in the 1903 release.
    Last edited by dbarrow; 10-02-2019 at 09:09 AM.

  10. #20
    Join Date
    May 2004
    Location
    Toronto Canada
    Posts
    2,816

    Default Re: Dropped buffers again

    Quote Originally Posted by dbarrow View Post
    I also updated my notebook computer to Windows 10 1903 from 1803. It has been running SAC all day, with music playing via foobar2000 through the wdm2 vst plugin on a stereo SAC channel, 24 other active tracks. I also have Firefox and Chrome open, ran another Audio/Video program, Transcibe!, all at the same time. SAC is set to 1-64 on this computer. NO DROPPED BUFFERS! I think they must have improved some performance aspects of Windows 10 in the 1903 release.
    Congrats! Thanks for sharing your experience. I wasn't aware of SpyBot Anti-Beacon


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •