Close

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Default No sound from imported midi file in MWS (an old newbie)

    A friend sent me a midi file of a piano part. I imported it to MWS and can see it. I can see meter activity, but I hear nothing (I can hear it in vlc media player).

    Since whatever minimal knowledge I'd gained about midi in MWS appears to have long ago vanished from memory - and everything I've attempted to glean from a surface read of the MWS manual and the scant few video clips I've watched has really only left me scratching my head in wonder - Could some kind soul write out a very basic step-by-step of getting sound from MWS playback of an existing imported midi file?

    All normal audio works fine on the studio/SAW pc. I have ZERO external midi devices, controllers, synths. So this is strictly a question of how to - I'm happy to use whatever general midi sounds that appear to be available in the list in MWS for now.

    I think I can figure out how to create/record an audio track from the midi playback in SAW and how to install and load a soft synth of some sort, once I can play this file. (I remember actually being to the point of learning to edit midi in MWS once a long time ago..... it's gone today and I'm getting flustered).

  2. #2
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    3,545
    Blog Entries
    1

    Default Re: No sound from imported midi file in MWS (an old newbie)

    UpTilDawn,

    I will answer your queries...each in turn [P#=posting, R#=response]
    * Please understand that due to the manner in which you have presented your queries, that this process is not in a sequential order.

    P1: A friend sent me a midi file of a piano part. I imported it to MWS and can see it. I can see meter activity, but I hear nothing (I can hear it in vlc media player).
    R1: You need to ensure that the Port and Channel information is configured correctly.

    P2: Since whatever minimal knowledge I'd gained about midi in MWS appears to have long ago vanished from memory - and everything I've attempted to glean from a surface read of the MWS manual and the scant few video clips I've watched has really only left me scratching my head in wonder - Could some kind soul write out a very basic step-by-step of getting sound from MWS playback of an existing imported midi file?
    R2: I have done so and will provide that to you in the next few days
    * I have a number of other "things" on the go at present. So, I do humbly ask that you please be patient with me...and I WILL get back to you very, very soon.

    P3: All normal audio works fine on the studio/SAW pc. I have ZERO external midi devices, controllers, synths. So this is strictly a question of how to - I'm happy to use whatever general midi sounds that appear to be available in the list in MWS for now.
    R3: To work with MIDI, you do require some kind of MIDI "device" - whether this be an external or an internal device. This is where VSTi's come into play - literally.
    * I provide everything you require in the tutorials that I am providing....so again, please be patient. Remember, "Anything that is worth doing - is worth doing right!" Hunter S. Thompson

    P4: I think I can figure out how to create/record an audio track from the midi playback in SAW and how to install and load a soft synth of some sort, once I can play this file. (I remember actually being to the point of learning to edit midi in MWS once a long time ago..... it's gone today and I'm getting flustered).
    P5: A complete tutorial is on its way!!

    PS: Are you deploying SAW32 or SAW64?
    * I have written dedicated tutorials on each platform.
    Last edited by mr_es335; 06-12-2024 at 08:43 AM. Reason: Update

  3. #3

    Default Re: No sound from imported midi file in MWS (an old newbie)

    Quote Originally Posted by UpTilDawn View Post
    A friend sent me a midi file of a piano part. I imported it to MWS and can see it. I can see meter activity, but I hear nothing (I can hear it in vlc media player).

    Since whatever minimal knowledge I'd gained about midi in MWS appears to have long ago vanished from memory - and everything I've attempted to glean from a surface read of the MWS manual and the scant few video clips I've watched has really only left me scratching my head in wonder - Could some kind soul write out a very basic step-by-step of getting sound from MWS playback of an existing imported midi file?

    All normal audio works fine on the studio/SAW pc. I have ZERO external midi devices, controllers, synths. So this is strictly a question of how to - I'm happy to use whatever general midi sounds that appear to be available in the list in MWS for now.

    I think I can figure out how to create/record an audio track from the midi playback in SAW and how to install and load a soft synth of some sort, once I can play this file. (I remember actually being to the point of learning to edit midi in MWS once a long time ago..... it's gone today and I'm getting flustered).
    There ARE a bunch of details that need to be tended to to make sound from MWS. But first: what are you using to generate audio? Are you going out to a hardware module? Or using a VSTi in SAW? If the latter, be sure you've set up the virtual MIDI ports there and in MWS.
    Dave "it aint the heat, it's the humidity" Labrecque
    Becket, Massachusetts

  4. #4
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    3,545
    Blog Entries
    1

    Default Re: No sound from imported midi file in MWS (an old newbie)

    UpTilDawn,

    Following is a link to the tutorial: [Click_me]
    Size: 13.993kb

    Notes: Part G and Part H might the two most significant sections for your perusal.



  5. #5

    Default Re: No sound from imported midi file in MWS (an old newbie)

    Quote Originally Posted by mr_es335 View Post
    UpTilDawn,

    Following is a link to the tutorial: [Click_me]
    Size: 13.993kb

    Notes: Part G and Part H might the two most significant sections for your perusal.


    Partial success! Thank you kindly, Dell.

    Got audio, following your instructions, using the SAW64 demo.

    Still no luck with my regular install...
    It must be in the settings.
    I need to retrace all the steps you outline in the tutorial and make sure I haven't accidentally made wrong changes in SAW, thinking it was MWS, or something. I can't get the plugin to load into the pre patch (Trouble loading plugin error).
    More testing later......

  6. #6
    Join Date
    Mar 2005
    Location
    Stuck in FL for now...
    Posts
    2,773
    Blog Entries
    1

  7. #7

    Default Re: No sound from imported midi file in MWS (an old newbie)

    I appreciate those tremendously Micro!
    I've been sifting through them, trying to sort out where they give me the answers I need to the most basic question I have - How do I get an existing, imported midi file (that I've listened to in vlc media player already) to playback an audio output? Your videos (so far) don't appear to address this - at least in a way I can translate into an answer. But I'm working on it.


    Update - still no luck with my regular install of SAW64/MWS64. No matter where I install the needed apps/dll/ini files, or how I've tried to direct SAW, the MIDI_player shows up in the SAW list, but will not load. I get - Trouble Loading PlugIn!

  8. #8
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    3,545
    Blog Entries
    1

    Default Re: No sound from imported midi file in MWS (an old newbie)

    UpTilDawn,

    May I ask where you are located?

    I can "remote-in" to your system and have a look-see...as long as your system has Internet connectivity.
    * The software I employ is 1) very small [5mb], and 2) does not require installation.

    Send me an email and we can look into this more.

    PS: It is the VSTi that is providing the audio output. If a non-VSTi plugin produces output, then the VSTi should
    produce output as well.

  9. #9

    Default Re: No sound from imported midi file in MWS (an old newbie)

    Email sent. Thanks Dell. It's got to be something simple.

  10. #10

    Default Re: No sound from imported midi file in MWS (an old newbie)

    Following up on the Remote-in that Dell graciously offered - as well as sending me a care package of a tutorial, utilities and links.

    I am very happy to report - initial issue solved! And a bit more useful knowledge and insight gained for my further exploration into an area of recording that I have basically avoided for many years.

    The initial issue - my ignorance of the process to produce audible sound from an imported midi file, was fixed by Dell's tutorial, which I ended up deciding to follow pretty much completely. That included installing the demo versions of SAW and MWS and the utilities Dell sent, including VST synth font 64 and a midi player.

    The installation and setting up ports, etc. was pretty painless on my own. Dell's help was indispensable, when tracing a problem loading the midi player into a channel (SAW's somewhat obscure "Trouble Loading PlugIn" error meesage (or whatever the wording is). issue turned up a faulty .ini file entry, with too many carriage returns (of my own making, I'm sure But who knew?! It's not like you can SEE 'em!.... ha!).

    Once resolved, I can safely say I am up and waddling through the world of midi muck to whatever new horizons I find.
    For the moment, I'm settling for playing the midi file sent to me and aimlessly amusing myself with the many different generic midi sounds offered. I even managed to build mix of two such sounds to a pair of MT hot tracks, where I can see comfortably familiar waveforms.

    Thanks again to Dell - very helpful and generous with your knowledge and time.

    Won't be long before I can make sense out of Micro's equally helpful video tutorials. I look forward to it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •