Close

Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    Default SAC crash when trying to load a mix file

    After three month I tried to start my SAC system today. Everything works fine until I tried to load a stored mix file. This will crash SAC as soon a I'll hit on okay.

    System is windows 8, SAC is most current 32 Bit version. It starts up with the mix-file automatically created when leaving SAC (shutdown.mxs ?) without problems. I tried to save this to an other mixfile, which succeeded but trying to load this file also crashes SAC.
    I tried both picking a file from the recent saved list or picking via open dialog.

    The pc was shut-down at the end of the last show ( 19th Dec 2020) and was not connected to the net since spring 2020.

    Any thoughts on this?

    My next steps will be:
    - backup current shoutdown.mxs and rename the file I want to use as shutdown.mxs and see if SAC will start up.

    Tomy
    Last edited by TomyN; 04-08-2021 at 03:28 AM.
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  2. #2

    Default Re: SAC crash when trying to load a mix file

    Status - Update:

    • Was able to fix the problem by deleting the pfr file.
    • Now I have an other strange thing going on
      • I had the plug-In Tape-It1 plugged into an output channel (Mixer 0, Output 1).
      • This plug-in does not show in the Fx - Setting window, but shows M00/01.
      • In the plug-in contains a second Echo/Delay plug ( Bob's plugin), which reports 'corrupt parameters' when you try to show the window assigned. Removing it from the list will not remove the tape-it plugin window.
      • I can add (and remove) an other instance of tape - it without any problems.
      • TapeIt (a normal VST2 plug in) resides in the VST Plugin Folder as DLL, and no trace of it can be found in the Nativ_Plugin folder

    • I'm able to save the mixfile and to load it again
    • On exit SAC crashes, showing


    Problemsignatur:
    Problemereignisname: APPCRASH
    Anwendungsname: SAC.exe
    Anwendungsversion: 0.0.0.0
    Anwendungszeitstempel: 5d125835
    Fehlermodulname: StackHash_abcc
    Fehlermodulversion: 0.0.0.0
    Fehlermodulzeitstempel: 00000000
    Ausnahmecode: c0000005
    Ausnahmeoffset: PCH_1E_FROM_ntdll+0x0003C20C
    Betriebsystemversion: 6.3.9600.2.0.0.256.48
    Gebietsschema-ID: 1031
    Zusatzinformation 1: abcc
    Zusatzinformation 2: abcc8f7853b48d9807d6d51eb1fa5df9
    Zusatzinformation 3: abcc
    Zusatzinformation 4: abcc8f7853b48d9807d6d51eb1fa5df9
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  3. #3
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,839
    Blog Entries
    1

    Default Re: SAC crash when trying to load a mix file

    Tomy,

    Love to help...but I am confused on what to do to resolve your issues. So, some suggestions and questions...

    1. It would be preferable to NOT doing anything until an issue has been resolved.
    * The deletion of the .prf file may now prevent anyone from assisting you further.

    2. What is the purpose of the shutdown.mxs file?
    * Can you please send me this file?

    3. I am not aware of SAC creating any data files on exit!
    * I just tested this out and am not seeing anything.
    * Can you please verify this anomaly?

    4. You state: "This plug-in does not show in the Fx - Setting window, but shows M00/01."
    * I am having no issues inserting and viewing the plugin.
    * See: [Image1]

    5. TapeIt is provided in a ZIP file.
    * All that I did was to extract the .dll and then copy that .dll to the VST_PlugIns folder.
    * See: [Image2]

    6. You stated: "no trace of it can be found in the Nativ_Plugin folder..."
    * The Native_PlugIns folder is for proprietary plugins - so VST2 plugins would not be displayed in the Native_PlugIns folder.

    I will await your response...

  4. #4

    Default Re: SAC crash when trying to load a mix file

    Quote Originally Posted by mr_es335 View Post
    Tomy,

    Love to help...but I am confused on what to do to resolve your issues. So, some suggestions and questions...

    1. It would be preferable to NOT doing anything until an issue has been resolved.
    * The deletion of the .prf file may now prevent anyone from assisting you further.

    2. What is the purpose of the shutdown.mxs file?
    * Can you please send me this file?

    3. I am not aware of SAC creating any data files on exit!
    * I just tested this out and am not seeing anything.
    * Can you please verify this anomaly?

    4. You state: "This plug-in does not show in the Fx - Setting window, but shows M00/01."
    * I am having no issues inserting and viewing the plugin.
    * See: [Image1]

    5. TapeIt is provided in a ZIP file.
    * All that I did was to extract the .dll and then copy that .dll to the VST_PlugIns folder.
    * See: [Image2]

    6. You stated: "no trace of it can be found in the Nativ_Plugin folder..."
    * The Native_PlugIns folder is for proprietary plugins - so VST2 plugins would not be displayed in the Native_PlugIns folder.

    I will await your response...

    1. I just renamed the configuration (prf) file.
    2. if you check the 'Autosave/recall shutdown session' SAC saves a shutdown.mxs file when you exit it, and loads this file on next startup.
    3. ?
    4. I did not have any issues with this plug in before either (and used it for at least five years). I'm able to add it into a fx slot and to remove it.

    When I load the mix file (checked with an other file too), the tapeIt window shows up (like your image 1), showing M:00 and O:01 as location
    Now I open the fx slot, and there is no tape-it listed, just a Studio_Fx_Eq (Pluged in by me) and TWO Studio_FX_Echo entries (one plugged in by me, showing my parameters (4ms each side in this case)), and one reporting 'invalid paramters' (or crashing when I click on it ( Studio_FX_Echo.dll in the crash report). Open the window it shows default settings (200ms, not dry, intensity to 50%).
    Then I remove the second Echo from the fx list, save the mix-file, exit SAC, restart SAC and load the file saved. And guess what, there are again two Studio_FX_Echo entries and the tape-It window shows up and shows M:00 O:01

    When I just do Save and try to load the file without restarting SAC, SAC will crash.

    5. Yes, it is unzipped
    6. Because it seems that SAC mixes up the Studio_FX_Echo (a native plugIn) and tapeIt1 (a VST2 plugIn) I just wanted to be sure that there is no confusion in the folders. But everything stays where it should stay.

    Which files shall I send you?

    Tomy
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  5. #5

    Default Re: SAC crash when trying to load a mix file

    Additional info: When I try to record using the 'ghost tape-it window' it lets me select a file name, and starts recording but indicates 'host sending no data' ( the background of the recording 'bullet' does not change to red).
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  6. #6
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,839
    Blog Entries
    1

    Default Re: SAC crash when trying to load a mix file

    Tomy,

    1. If you check the 'Autosave/recall shutdown session' SAC saves a shutdown.mxs file when you exit it, and loads this file on next startup.
    * I was unaware of this option...and am not sure why I would ever use it.

    2. Because it seems that SAC mixes up the Studio_FX_Echo (a native plugIn) and tapeIt1 (a VST2 plugIn) I just wanted to be sure that there is no confusion in the folders. But everything stays where it should stay.
    * May I ask what you mean by "mixes up"?
    * In order for a plugin in the Native_PlugIns folder to be acknowledged by SAC, the SAC_FX_Native.ini file must be updated. This cannot be done with VST2 plugins - as this will cause SAC to crash.
    * The default entries for the SAC_FX_Native.ini file are as follows:

    Studio_FX_Echo.dll
    Studio_FX_Eq.dll
    [an empty line]

    3. If you have not yet done so, maybe check out this text...

    4. Whenever I am attempting to troubleshoot an issue, I first attempt to find the "trigger" - that is, what has changed since I last used the application. I try to ensure that I am able to "back out" of a change - to be able to return to the original problem. Once discovered, I then second will try to replicate the error.

  7. #7

    Default Re: SAC crash when trying to load a mix file

    Hi,

    Thanks for your reply.


    • I agree with you regarding the way to troubleshoot. But in this case, the systems works on the last show, I shut it down and put it into my warehouse. Today I wanted to prepare it for the next event and SAC crashed on loading (with any file I tried to load). I looked for anything I changed on the date of the last show and removed it (just a remote software for my controller). No change.
    • Digging deeper into the mix-file, I found an other output - channel containing a 'double plug in'. When I try to remove the ghost plug-in, SAC crashes (SAC.exe). I tried removing with engine running, engine stopped and via Clear channel entry in the menu. Tried with tapeIt.dll available and with tapeIt.dll renamed. Always the same effect.
    • I assume that for any reason SAC creates an instance of the tape-it.dll without assignment, and defaults its settings to an other plug-in.


    Tomy
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  8. #8
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,839
    Blog Entries
    1

    Default Re: SAC crash when trying to load a mix file

    Tomy,

    What do you mean by "ghost tape-it window"?

    You stated, "But in this case, the systems works on the last show, I shut it down and put it into my warehouse. Today I wanted to prepare it for the next event and SAC crashed on loading (with any file I tried to load)."

    Arthur Conan Doyle stated, "When you have eliminated all which is impossible, then whatever remains, however improbable, must be the truth." Something then, must have occurred at the time the system was last shut down. The question then is" What occurred?" Believe it not - something must have happened at the time the system was last shutdown.

    I would suggest that you disable "Autosave/recall shutdown session" and see what happens?
    * Make sure that you update the Preferences file.

    1. If SAC loads OK, then create a new session with TapeIt inserted into a channel
    2. Save the session - call it "First"
    3. Then exit SAC
    4. Re-launch SAC, load the previously saved "First" session file - and see what happens.
    5. If SAC loads OK, then create another new session with TapeIt inserted into a channel
    6. Save the session - call it "Second"
    7. Then exit SAC
    8. Re-launch SAC, load the "Second" session file.
    9. If OK, then, load the "First " session file.
    10. If all is OK, then the issue must be with the shutdown.mxs file.

  9. #9

    Default Re: SAC crash when trying to load a mix file

    Just describe the situation:
    • A tapeit window will show during load, showing M:00 O:01 in its menu bar. When you click on 'record' in this window, then the save-dialog opens up and you can set a file name. Recording will not start but remains in Host does not send data state, which means that this plug in does not reside in a fx - slot, because otherwise it would get data as soon as the engine starts. Therefore I called this window 'tapeIt ghost window'.
    • The fx slot of M:00 O:01 contains no tapeIt entry, but an additional Studio Echo entry. When you click on this entry, you get either an 'corrupted settings' message (most of the time) or the plug in makes SAC crash ( STUDIO_FX_ECHO.dll in crash report). You can remove the entry from the list, but it will be back next time you load the file.
    • I can add and remove an other tapeIt entry in the same (or an other) slot, which works as exspected.
    • In an other output (O12) there is also a 'ghost line', which doubles the Vst-FX assigned to this slot ( lightweight compressor). Trying to remove this entry crashes SAC.
    • When you rename the tapeIt.dll you'll get a 'corrupt parameters in tapeIt' warning when you load the file and the 'ghost window' will not show, but the ghots lines are still there. And no chance to remove the ghost lines from 012.
    • You can save the mixfile without any problem.
    • Leaving SAC will crash it.


    I was able to create a working version of this file performing this steps
    1. Save a copy of the mix file onto an usb stick
    2. Open this file on my desktop pc using SAC32 demo. During loading SAC complains about missing Vallhala and Chorus plug-ins, but not about missing tapeIt plugin.
    3. Now I was able to remove the ghost lines in both output channels.
    4. Saved the file using a different file name.
    5. Put the new file on my main SAC machine.
    6. File loads without any problem. No ghost window. Need to reassign Vallhala and Chorus (as I've exspected).
    7. SAC shuts down without problem ( with or without shutDown auto-save/recall enabled).
    8. Problem remains with original file.


    Reasons I could think of:
    1. A 'hidden' setting either in tapeIt or in SAC that invokes tapeIt.dll during loading even when it is not in the mxs file.
    2. The tapeIt call is in the mxs file, but due to some reason it lost its assignment (but still shows M:00 O:01).
    3. Some crude interaction between VST plugins..


    I'd be happy to supply the files for further analysis.

    Tomy
    Last edited by TomyN; 04-08-2021 at 11:37 AM.
    3 * TIO1608 + AIC-128 + X-Touch + Dante -> AES + DADC-144DT

    SATlive is my measurement software
    DIN 15905-5 (German SPL Limit)

  10. #10
    Join Date
    Oct 2009
    Location
    Maple Ridge, BC Canada
    Posts
    2,839
    Blog Entries
    1

    Default Re: SAC crash when trying to load a mix file

    Tomy,

    If you would be so kind as to try the above suggested procedure...thanks,

    Yes, send me the data...
    * PS: How "big" is your entire SAC folder?

    Okay, I have tested the TapeIt plugin - M:00 - I01 which is saying in effect FOH and CH1.

    I have "Autosave/recall shutdown session" enabled.

    Again, please complete the above procedure and let me know how all goes. Step-by-step is preferable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •